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How To Import OS Superplan Data Files into CAD Systems 
 
 
So you want import OS Superplan data into your CAD system? 
  
Perhaps you have just received an email or disk containing Superplan data files in 
.zip or .dxf format and you are not sure what to do next, maybe you are wanting a 
few tips on how to best use the data, or you are just researching the whole subject 
of vector mapping and Superplan data, then it is my hope that this paper will lead 
you in the right direction 
 
This paper’s main objective is guide you in the process of importing Superplan Data 
into a CAD system, the paper also briefly covers the type of information included in 
Superplan Data and few tips on manipulating the data inside a CAD system. 
 
Whilst not a pre-requisite to reading this paper, it would be very handy if you had 
access to both a CAD system and some Superplan Data files. If you haven’t got 
access to you own Superplan Data files that you can download a couple of samples 
by visiting www.conesoftware.com/whitepapers 
 
 
 
What Is Superplan Data? 

Superplan is the most detailed mapping of Great Britain and Ordnance Survey’s 
most easily available business-to-business mapping. 

The data is designed to allow you to add your own information and overlay it 
against an industry standard, recognised dataset. It is supplied in DXF format that 
is compatible with most CAD systems. 
 
If you are new to Superplan Data or accidentally came across this paper then may 
you may wish to read two other documents in the series named:  

High resolution aerial photographs and large scale vector maps 
they are easier to obtain and cheaper than you think  
 
How to import OS Superplan Data - Large Scale Digital Vector Maps Into CAD 
systems 
 
Both are freely available from the following website 

www.conesoftware.com/whitepapers  
 
  

 

 

www.conesoftware.com/whitepapers
www.conesoftware.com/whitepapers


 

How to import OS Superplan Data - Large 
Scale Digital Vector Maps Into CAD systems 

 

 
Copyright  © 2005 CADaptor Solutions   
www.cadaptor.co.uk  -- Tel: +44(0) 1274 780703                           Page: 2 

 

How is Superplan Data Supplied? 

Superplan Data is supplied in Drawing Interchange Format (DXF) that is fully 
compatible with AutoCAD release 12 onwards.  The data is delivered via email or 
CD-ROM and is supplied as-is and does not include any software for you to use it as 
it stands.  
  
In order to import the Superplan Data you will need software that can read 
drawings in DXF. Most modern CAD packages can import DXF files and this paper 
describes the import methods for the following popular types: 
 
AutoCAD (including specific packages such as Autodesk Map and ADT) 
AutoCAD LT 
Autosketch 
AutoCAD Clones such as Intellicad 
CorelDraw 
 
If your CAD package is not amongst those listed above then you may want to search 
your system documentation for topics like Import and DXF 
 
 
If your Superplan Data files were supplied by email they will probably be in the 
form of a compressed zip file. If so, the file name is the drawing reference number 
suffixed by .zip, for example, 18000234.zip  
 
Before loading into CAD, you will need to decompress the file to recreate the 
original DXF file. If you haven’t got any Unzipping facilities on your computer then 
you are advised to download the latest WinZip program from 
http://www.winzip.com/ 
 
If your Superplan Data files were supplied on CD ROM then they will be 
uncompressed and you can import the .dxf file into your CAD system immediately 
 
 
Importing DXF Files into AutoCAD, AutoCAD LT and AutoCAD Clones 
 
Start an AutoCAD session. 

1. From the File menu, choose Open.  
2. In the Select File dialog box, in the Files of Type box, select DXF (*.dxf).  
3. Find and select the DXF file you want to import, or enter the name of the 

DXF file at File Name.  
4. Choose Open. 
5. From the View menu, choose Zoom then Extents 
6. From the File Menu choose Save As to save the drawing as a .DWG file 

 
 
Once a '.DWG' file has been created in this way, the original .DXF file is redundant 
and you can now move on to the Tips and Tricks section  
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Importing DXF Files into AutoSketch 
 
 
Start an Autosketch session. 
 

1. From the File menu, choose Open.  
2. In the Select File dialog box, in the Files of Type box, select Drawing 

Interchange (*.dxf).  
3. Find and select the DXF file you want to import, or enter the name of 

the DXF file at File Name.  
Choose Open. 

4. Select Metres from the Linear Scale Factor units pop-down list 
5. From the File Menu choose Save As to save the drawing as a .SKF or .DWG 

file 
 
 
Once an .SKF or '.DWG' file has been created in this way, the original .DXF file is 
redundant and you can now move on to the Tips and Tricks section  
 
 
 
Importing DXF Files into CorelDraw 
 
 
Start a CorelDraw session. 
 

1. Click File > Open 
2. Locate the folder where the file is stored. 
3. Choose DXF - AutoCAD from the Files of type list box. 
4. Click the filename. 
5. Click Open. 
6. In the Import AutoCAD file dialog box, choose a plane projection of a 

three-dimensional object as seen from a given focal point from the 3D 
projection list box. 

7. If you want to reduce the number of nodes on the imported object, enable 
Auto-reduce nodes.  

8. In the Scaling area, enable one of the following options: 
a. Automatic — scales the drawing using the scale of the AutoCAD 

source file 
b. English (1 unit = 1 inch) — lets you scale the drawing in inches 
c. Metric (1 unit = 1 mm) — lets you scale the drawing in millimeters 

9. From the File Menu choose Save As to save the drawing as a .CDR file 
 

Once an .SKF or '.DWG' file has been created in this way, the original .DXF file 
is redundant and you can now move on to the Tips and Tricks section 
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Tips and Tricks 
 
Save It 
 
No matter what CAD system you import the Superplan Data DXF file into I 
recommend that you save the resultant drawing in the CAD systems native file 
format. 
 
.DWG for AutoCAD, AutoCAD LT and clones 
.SKF for Autosketch 
.CDR for CorelDraw 
 
 
Have you got the right scale? 
 
One of the best uses of vector maps such as Superplan Data inside a CAD system is 
the ability to accurately measure distances between points on the map (i.e. The 
width or length of a road or building etc.) If you used the Open DXF methods as 
described above then the units should be set to metres and if you measure the 
distance between any two vertical or horizontal grid lines the answer should be 
100. (The distance between grids is 100 metres) 
 
In AutoCAD use pull down Tools > Inquiry > Distance 
Pick 2 points, the result is given at the command line 
 
In Autosketch use pull down Inquire > Distance 
Pick 2 points and then select the pull down list to see the distance in a number of 
different units 
 
In CorelDraw use the dimension fly-out from the freehand tool icon 
Pick 2 points, the result is given in the status bar 
 
If the distance is not 100 then I recommend you scale the map accordingly for 
example if the distance between two grid lines is 2540.0 then you should scale the 
map by 100 / 2540.0 = 0.01 
 
 
 
 
Sort out those Layers 
 
You will probably notice that there are quite a number of layers (up to 60 in fact) 
and these have very unmemorable names such as G8030001 and G8030021.  
 
Layers are pretty useful things to have on a map it will allow you to turn the 
visibility of certain objects such as buildings, trees, water features, piping etc On 
or Off. 
 
A useful tip is to turn all the map layers OFF and then selectively turn each layer 
ON in turn to see the effect and to get used to the layer naming convention. 
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I also recommend that you rename the layers that you are going to be using 
frequently and switch off the layers you will not be using 
 
i.e. Rename G8030001 to Building Outlines and rename G8030021 to Road Edge 
etc. 
 
The table below lists all layers that can be found in Superplan Data. The BS1192 Pt 
5 layers are in numerical order. Also shown for each layer are a description 
(common name) and Colour.  The colours shown are default and may vary 
according to your system and software’s configuration. 
 
I recommend that you rename the layers that you are going to be using frequently 
and switch off the layers you will not be using 
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Layer  Description   Colour  

  

G8030001 Building outline   red 

G8030004 Building outline (overhead)  red 
G8030007   Civil Parish/Community Boundary                    magenta  

G8030008  District/London Borough Boundary                    magenta 

G8030009  County  Boundary                                              magenta 

G8030010  Electoral Division/Ward                                      magenta 

G8030011   Boundary post/stone                                         magenta 

G8030013  Boundary mereing symbol                                 magenta        

G8030014 Railway (narrow gauge)  blue 

G8030015 Railway (standard gauge)     blue 

G8030021 Road (public) edge of metalling  blue 

G8030025 Triangulation point   blue 

G8030026 Bench mark   blue 

G8030027 Spot height                      blue 

G8030030 General line/ minor building detail  white 

G8030032 General ground level/ minor overhead detail white 

G8030033 Underground detail/ course of antiquity blue 

G8030035 Vegetation/ landform limit (secondary) green 

G8030036 Vegetation/ landform limit  green 

G8030043 Overhead detail   blue 

G8030049 Pylon    blue 

G8030052 Minor detail                      
white 

G8030057 Point feature   white 

G8030059 Water detail   cyan 

G8030069 Flow arrow    cyan 

G8030071 Mean High Water (Springs)  cyan 

G8030072 Mean Low Water (Springs)  cyan 

G8030079  European/Westminster Boundary                      magenta 

G8030321 Roofed building indicator  red 

G8030323 Glasshouse indicator   white 

G8030372 Positioned coniferous tree  green 

G8030373 Positioned  non-coniferous tree  green 

G8030374 Top of slope   red 

G8030375 Top of cliff    red 

G8030376 Bottom of slope or cliff   brown 

G8030377 Boulders    brown 

G8030378 Boulders (scattered)    brown 

G8030379 Coniferous trees    green 

 
 

Layer  Description               Colour  
 

G8030380 Coniferous trees (scattered)  green 

G8030381 Coppice/ osiers   green 

G8030382 Marsh/ saltmarsh/ reeds  green 

G8030384 Non-coniferous trees    green 

G8030385 Non-coniferous trees (scattered)   green 

G8030386 Orchard     green 

G8030387 Heath    green 

G8030388 Rock    brown 

G8030389 Rock (scattered)   brown 

G8030390 Rough grassland    green 

G8030392 Scrub    green 

G8030395 Upper level of communication indicator magenta 

G8030396 Cliff indicator   brown 

G8030397 Slope indicator   brown 

G8030400 Water indicator   cyan 

G8030570 Copyright symbol   white 

G8030571 Footnotes, scale bar, logo, etc  white 

G8030572 Internal gridlines and values  white 

G8030573 Neat line and corner values  white 

G8030574 Customer reference title  white 

G8030575 Drawing reference number  white 

G8031000 Road name/ number   white 

G8031005   Boundary  text                                                   magenta 

G8031006 House number/ building name  red 

G8031009 Miscellaneous text                                      blue    
G8031010 Water text    cyan 

G8031013 Land parcel number   green 

G8031210 Scree    brown 

G8031211 Positioned boulder   brown 

G8031212 Ridge/ rock line   red 
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Where to go from here 
 
This paper is one of six papers in the series the others being: 
 
High Resolution Aerial Photographs and Large Scale Vector Maps their easier to 
obtain and cheaper than you think 
 
How to easily obtain OS Superplan Data - Large Scale Digital Vector Maps 
 
How to easily obtain High Resolution Aerial Photography and OS MasterMap 
Topographic information 
 
How to import Aerial Photography, OS MasterMap Topographic and Other Raster Map 
Images Into CAD systems 
 
How To Best Use Maps (Raster or Vector) and Aerial Photography when producing 
Road Traffic Control Diagrams 
 
 
All are freely available from the following website 
 
www.conesoftware.com/whitepapers 
 
 
 
About The Author 

 

Peter Booth is sole owner of CADaptor Solutions a UK company who are the sole 

developers and distributors of CONE, a software package that aids the production 

of temporary traffic control diagrams and route diversion schemes.  

CONE is used extensively in the Road Traffic Industry and has a 12-year pedigree. 
You can find out more about CONE by visiting www.conesoftware.com 
 
 
Trademarks 
 
Ordnance Survey and the OS symbol are registered trademarks and Superplan are 
trademarks of Ordnance Survey, the National Mapping Agency of Great Britain. 
 
DXF is a trademark and AutoCAD is a registered trademark of AutoDesk Inc. 
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